Terug naar overzicht
Opgelost

Mail Server is offline

Jul 13, 2026 at 4:00am UTC
Getroffen diensten
Mail Server

Opgelost
Jul 13, 2026 at 5:21am UTC

Mail Server is hersteld.

Bijgewerkt
Jul 13, 2026 at 5:15am UTC

Mail Server is offline gegaan.

Bijgewerkt
Jul 13, 2026 at 4:51am UTC

Mail Server is hersteld.

Bijgewerkt
Jul 13, 2026 at 4:45am UTC

Mail Server is offline gegaan.

Bijgewerkt
Jul 13, 2026 at 4:05am UTC

Mail Server is hersteld.

Aangemaakt
Jul 13, 2026 at 4:00am UTC

Mail Server is offline gegaan.