Terug naar overzicht
Opgelost

Mail Server is offline

Jul 12, 2026 at 11:09pm UTC
Getroffen diensten
Mail Server

Opgelost
Jul 12, 2026 at 11:14pm UTC

Mail Server is hersteld.

Aangemaakt
Jul 12, 2026 at 11:09pm UTC

Mail Server is offline gegaan.